Crowds yesterday 5/20/2019

Wednesday, May 22, 2019 12:20 PM
operative_me's avatar

Yeah the pouches are definitely clunky. And even with the lap bar town I could still access mine if I wanted. Maybe I just got a Stretch Armstrong thing going. From what I saw yesterday, even with the train ready to go, they didn't dispatch until the previous train completed the circuit. Maybe this is due to a new crew, I hope so.

What drives me nuts is they are using 2 people to man each metal detector, for a total of 4 people. They literally could have 2 people in the station with carts or bins of some sort and be much more effective. Hell when I was at Dollywood last month they had workers taking loose items from Lighting Rod riders and stashing them for them, and everything was just fine.


-Craig
Lifetime Laps on Woodstock Express: 0

+0
Wednesday, May 22, 2019 12:36 PM
jimmyburke's avatar

Thabto said:

I was at the park yesterday and everything was walk on except SV. That was my first time riding it with the new pockets. I think the metal detectors and the pockets slow everything down although I did notice that all 3 trains weren't stacking each time so I'm not sure. SV didn't open until around 12:30. I heard the late openings have been due to cool temperatures in the morning.

Brian, were you wearing the hoodie with a diagram of a blimp on the back? If so, nice hoodie. My son & I arrived at 2:15, and yes, everything was a walk-on.

+0
Wednesday, May 22, 2019 12:41 PM
operative_me's avatar

Eh looking around this and other sites, it does seem like they have been dispatching SV sooner than I witnessed yesterday, so that is good news. Hopefully yesterday was an anomaly.

The MCBR didn't do a thing for my ride yesterday, so who knows what is going on there.


-Craig
Lifetime Laps on Woodstock Express: 0

+0
Wednesday, May 22, 2019 1:52 PM
Thabto's avatar

Yes. I was wearing a blimp hoodie.


Brian
Valravn Rides: 23| Steel Vengeance Rides: 23| Dragster Rollbacks: 1
2020 Visits: 2 Next Visit: Don't know yet

+0
Wednesday, May 22, 2019 2:06 PM
ImpulsivePhoenix's avatar

The MCBR isn't going I have to imagine due to the cold temps. I have noticed the ride having a slower first half as it gets to it. It will start going once it gets hot.


Sacrificing playing video games to ride roller coasters.

+0

You must be logged in to post

POP Forums app ©2020, POP World Media, LLC - Terms of Service